Announcement

Collapse
No announcement yet.

Wordpress Database Switch

Collapse
X
 
  • Filter
  • Time
  • Show
Clear All
new posts

  • Wordpress Database Switch

    Okay, here is the situation:

    I have a customer who has be hosting an active customized WordPress site with me for a few years under one url, abc.com.
    They purchased a second url, xyz.com, and asked me to transfer the old site over to the new url.
    I then installed the same version of WordPress with the same theme on the new url.
    I used the old database, and at first glance they were perfect working copies of each other, including Pages, Posts, and Graphics...
    I was happy. My client has the intention of only using the new url after the old one expires. That is why I installed a new site instead of just pointing the new url at the old one.

    The Problem:

    I felt something was off so I performed a little experiment. I temporarily disabled the first site, abc.com.
    Then I tried to load the new url, that was just working, and got the error: Object not found! - Error 404
    After reinstalling the new url it now just show the text without formatting or graphics. when the old site is disabled.

    Recap:

    Sites abc.com and xyz.com share the same database.
    If site abc is disabled site xyz also stops working.
    No changes have been made to the database.

    What else I've tried:

    I've tried to copy all of the files from abc over to xyz, but the file structure does not copy correctly (I've in countered this problem a lot.).

    What I need:

    I need your help in figuring this out. How can I fix this problem?


    Thank you.

  • #2
    Sent you a pm iads

    Comment


    • #3
      doneritehosting,

      Thanks so very much!!! It worked better then perfect. Not only is site xyz working correctly, but now we have a complete reversal of the problem where abc now stops working when xyz stops, but it's okay since that domain will be deleted when the url expires. The only little change that I had to grasp in my mind was due to the fact that they were on the same server/hosting account. Again thanks.

      Comment


      • #4
        You are most welcome iads, I'm glad it worked out

        Comment


        • #5
          It sounds like you need to do a search and replace of the URL's in your database, search for oldsite.com and replace it with newsite.com. This usually only affects images and media, but can sometimes affect permi-links if you have this feature switched on.

          Comment


          • #6
            That was the problem clivejo it was late so i refered iads to a article i have published for wp migration.
            Last edited by doneritehosting; 27-09-2013, 09:49 PM. Reason: Sleepy fingers lmao

            Comment


            • clivejo
              clivejo commented
              Editing a comment
              Mind posting a link for anyone else with the same problem?

            • doneritehosting
              doneritehosting commented
              Editing a comment
              no problem clivejo ill do it this evening

          • #7
            Ok here is a link to the article clivejo and anyone else who needs the information

            http://www.doneritehosting.net/migra...rent-web-host/

            Comment


            • #8
              Great post doneritehosting!!! Thank you.

              Comment


              • doneritehosting
                doneritehosting commented
                Editing a comment
                Thanks Tom, Appreciate it
            Working...
            X