Announcement

Collapse
No announcement yet.

Twitter Card Validator

Collapse
X
 
  • Filter
  • Time
  • Show
Clear All
new posts

  • Twitter Card Validator

    I was running a few of my wordpress hosting page urls through the twitter card validator, https://cards-dev.twitter.com/validator, and noticed that some of the card previews will either have a blank name for my site title or display [rp_store_info key='store_title'].

    Have any others come across this issue? If so, what did you do to fix it?

    I have edited a few pages replacing [rp_store_info key='store_title'] with my actual site title and it shows fine but my concern is having to go through and fix all these whenever a theme or rsp plugin is updated.

    Thanks, John

  • #2
    I had this problem when trying to use a logo... to my knowledge none of rsp themes support not displaying the site title / tagline when using a logo. they will display along with the logo. As you have to remove your site title / tag line from the fields so the logo displays correctly, there is no information for the shortcode to actually display...

    There are basicly 3 senerios here...

    1 - do as I do and do not use a logo (resolves problem)

    ​2 - Use a logo and manually change the short codes. (resolves problem) Time consuming and you are right with your concern of future theme / plugin updates

    ​3 - Contact support and ask them to add the feature to the themes to choose to not display site title / tagline when using a logo and this is the real fix for the problem.. I have mentioned this to support in the past but it has not been taken care of yet... be sure to file your ticket though lol

    ​Its not just the twitter validator this affects.... it also cripples most seo plugins when using a logo with no site title / tagline.... Also causes your site to be spidered incorrectly for search engines and seo with shortcodes in the titles and description listing google / bing/ etc etc....

    ​Luck to you Rug3r
    Last edited by doneritehosting; 11-09-2016, 11:09 PM.

    Comment


    • #3
      Thanks for the reply doneritehosting,

      The only thing I had edited was the header.php changing
      Code:
          <div id="header">
              <h1 id="header_logo"><a href="<?php echo home_url()?>"><?php bloginfo('name')?></a></h1>
              <h5 id="header_logo"><?php bloginfo('description')?></h5>
          </div>
      to
      Code:
          <div id="header">
      
              <h1 id="header_logo"><a href="<?php echo home_url()?>"><img src="https://mysite.com/wp-content/uploads/my-logo_light-268x58.png" /></a></h1>
      
              <h5 id="header_logo"><?php bloginfo('description')?></h5>
      
          </div>
      That way the description is still there. And made some changes to the style.css to make it all fit fine in the header as well as just hiding it on mobile css settings since the description wouldnt fit right.

      Thing is I have reverted to the complete stock theme settings and tested this as well and I get the same problem.

      An example of running the ssl page: Click image for larger version

Name:	image_354.png
Views:	71
Size:	99.2 KB
ID:	62434




      And the html for the page:
      Code:
            <h2>Affordable SSL Certificates from [rp_store_info key='store_title']</h2>
          </center>
          Nowadays, protection is a vital internet site management element. With an SSL Certificate

      And this is running the stock theme no logo or edits.

      When I did have the edits using my logo I didn't notice any problems on google with my SEO

      Still have some final touches for Yoast though.

      Anyone else notice this problem that hasn't edited their WP theme?
      Last edited by Rug3r; 12-09-2016, 12:20 AM.

      Comment


      • #4
        [rp_store_info key='store_title'] for some reason this shortcode is not pulling your store name (site title) as defined from WP admin settings As I have said above I have only run into this by removing them so I could use a logo. Got the same results you are getting....

        ​Sorry I cant be no more help than this and would be interested if you find a fix

        Comment


        • #5
          What SEO plugin do you use or you don't use any of them?
          I'm using all in one seo and its seems that plugin can use short codes in descriptions and titles

          Comment


          • #6
            Im using yoast seo. Been running it on another wp site hosted elsewhere and doesnt have any problems with shortcodes.

            Comment


            • #7
              I'm using all in one seo I actually can see a faster loading time in page speed tests using it.... only weak point I have found of it is the rich editor being disabled in rsp themes and causes it to pull html in the auto generated description tags for the header... It only takes a couple of minutes to correct this though before publishing so I'm good with it.

              Comment


              • #8
                did you try to copy paste metas?

                Comment

                Working...
                X