Announcement

Collapse
No announcement yet.

How to enable memcached?

Collapse
X
 
  • Filter
  • Time
  • Show
Clear All
new posts

  • How to enable memcached?

    Hi,

    Does anyone have memcached working with the W3 plugin for WordPress? I have created an instance and enabled it in PHP setting in the Control Panel, W3 can "see" it and I can select it from the drop down box, but it keeps throwing an error

    The following memcached servers are not responding or not running:
    • Page Cache: 127.0.0.1:11211.
    Anyone know what is wrong?

  • #2
    Hello,

    Please note that in Hepsia environment connecting to the memcached instance isn't done via port but via unix socket instead. You will need to configure your Memcached plugin to connect to:


    unix:///home/sys/memcached.sock


    Best Regards,
    Nick Green,
    Technical Support Department.

    Comment


    • #3
      Thanks for that.

      So basically for others to follow along, once enabled as above, you then need to enable it in the W3 Total Cache plug-in. This is the bit was confusing me!

      You have to enable it first, ie Performance > General Settings > Page Cache > Select Memcached > Save settings which will throw an error

      Click image for larger version

Name:	enable_memcached.png
Views:	144
Size:	71.3 KB
ID:	64285

      Then go into Performance > Page Cache > Under Advanced settings > and change
      Code:
      Memcached hostname:port / IP:port: 127.0.0.1:11211
      to
      Code:
      /home/sys/memcached.sock:0
      And so on for DB and other caches...
      Last edited by clivejo; 15-10-2021, 09:07 PM.

      Comment

      Working...
      X